Symptoms
Unable to complete the product registration with error message "An unexpected error occurred on the server. Check your internet connection and try again"
Cause
Windows' Host file has Corel links which blocks the registration process
Resolution
Empty the User Temp folder
- Press Windows key + R to open the Run dialogue box
- Tyoe %temp% and press Enter
- Press CTRL and 'A' together to select all the contents
- Press SHIFT and DEL together to clear the folder
NOTE: There will be some items which will not delete. This is fine. Simply click the checkbox to perform the action again automatically and click Skip
Check the Windows HOSTS file
- Press Windows key + R to open the Run dialogue box
- Type in drivers and press Enter
- Double-click on the folder etc
- NOTE: Because of system permissions, you will not be able to open the HOSTS file and save any changes from within this folder
- Copy the HOSTS file to the Desktop; Minimize this window
- Right-click the HOSTS file on the Desktop, Choose Open With... then Notepad
- In this folder look for the following entries and remove them:
- 0.0.0.0 apps.corel.com
- 0.0.0.0 mc.corel.com
- 0.0.0.0 origin-mc.corel.com
- 0.0.0.0 iws.corel.com
- 127.0.0.1 mc.corel.co
- 127.0.0.1 apps.corel.com
- 127.0.0.1 origin-mc.corel.com
- 127.0.0.1 iws.corel.com
Once you have removed these entries from the file, Save the file by pressing CTRL+ S. After which, you can copy and paste the file back into the ETC folder, which was minimized, and agreeing to the security prompt.
Resetting Internet Options
- Press Windows key + R to open the Run dialogue box
- Type in Control and press Enter
- In the upper right corner you will see a drop-down with Category View selected. Click on this option and select either Large or Small Icons
- Double-click on Internet Options
- Click on the Security tab at the top of the window
- Click each heading at the top of this screen, pressing Default Level on each
- Press Apply
- Click the Advanced Tab
- Click on the button labeled Restore Default Settings (Windows 10 and below) / Restore Advanced Settings (Windows 11)
- Press Apply
- Press OK
Once you are done these steps, Restart Windows and then launch your program and try to sign in.
Should this fail, please Contact Technical Support for further instructions
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