Symptoms
When you attempt to launch the Roxio Video Capture app (Easy VHS to DVD for Mac software), it prompts you to connect the Roxio Video Capture Hardware to any USB port on your Mac.
Having plugged in your Roxio capture device, it still does not launch the app; and the prompt to connect the capture device will not go away.
Cause
This issue may have several known causes and, hence, different resolutions.
Your Roxio capture device model
You are using an older Roxio video capture USB device - model# UB315-E ver. 3 and your Mac is running on macOS 10.15 (Catalina) or later. There were no 64-bit system extensions/drivers written for this particular model to run on the newer macOS versions. Hence, the app failing to recognize the device.
Third-party capture device
This can also happen if you are using a 3rd-party (non-Roxio) video capture USB device.
Your macOS version (Sonoma 14.1)
It has been discovered that due to a change in the support for older API libraries it depends on, the Roxio video capture app no longer recognizes the Roxio capture device.
Resolution
Depending on the cause for which your Roxio video capture app is no longer recognizing your Roxio capture device, you may apply the following fixes or workarounds.
Older Roxio capture device model
If you are using the older Roxio capture device, two options are available:
- You can either use the product on a Mac running macOS 10.14 (Mojave) or earlier, or downgrade your current macOS to these earlier version;
- Purchase the latest version of the product, which includes the compatible Roxio capture device, model# HU3180-E.
Unsupported 3rd-party device
If you are using a 3rd-party video capture USB device, you will need to revert to your Roxio capture device model and take note of the details above.
Recent upgrade to macOS Sonoma 14.1
This only applies to macOS 14.1. If you have macOS 14.0, this section is not applicable to you.
If you have recently upgraded to macOS Sonoma 14.1 and noticed that your Roxio video capture USB app has stopped working, this is due to the aforementioned changes in the support for older API libraries. Apple has published a knowledgebase article that explains this situation, and how to re-enable your "legacy" video device by modifying some settings on your Mac. Please click on this link to read the article.
There will be cases where the entered command string will produce an error in Terminal stating something similar to Volume on disk3s1 failed to mount. This is an encrypted and locked APFS Volume; use "diskutil apfs unlockVolume". In such cases, the problem is caued by FileVault being turned on. Please follow the procedure in this link to disable the feature.
We hope this article helped in resolving your Roxio video capture USB app issue. If the issue persists, please reach out to our Roxio technical support team.
Was this article helpful?
Tell us how we can improve it.