Painter Essentials : Is my version of Painter Essentials compatible with macOS 11.0 (Big Sur)?

2 users found this article helpful

Painter Essentials 8 is compatible with macOS Big Sur. Earlier versions of Painter Essentials can only be used with the versions of macOS 10.x they were designed for.  

Was this article helpful?

Tell us how we can improve it.