AfterShot Pro 3: Upgrade Eligibility

0 users found this article helpful

To purchase the upgrade version of AfterShot Pro 3, you must own a previous licensed version of: Bibble Pro or Lite 5, Corel® AfterShot Pro®, Corel® Paint Shop Pro® Photo X2 or higher, Adobe® Lightroom® or Apple® Aperture®.

Was this article helpful?

Tell us how we can improve it.