Roxio Toast: Disc burning is interrupted with error "One or more files are open" or "Result code= -47"

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Symptoms

When burning files to DVD or Blu-ray disc, or saving to a disc image file using either of those formats, the process gets interrupted and an error message comes up on your screen stating, "Couldn't complete the last command because one or more files are open. Result code= -47".

Cause

It may seem obvious, considering what is stated in the error message, that some of the files you are attempting to burn are open in or in use by another application. But this may not always be the case. More often then not, there are no applications using the files. Instead, an overzealous antivirus software is "protecting" and preventing these files from being used by Toast.

Error result code= -47       Error -47 in High Sierra

Resolution

The first thing you need to do, as mentioned above, is to check if you have any open application that may be using those files you want to burn. For instance, if you are trying to burn a slideshow of pictures and you own Adobe PhotoShop, see if PhotoShop is open and quit the application if so. If you have another user account on your Mac, that user account may be simultaneously signed in and your files are shared with and open in that account. Make sure all other user accounts on your Mac are signed out.

If none of the above is true, then the culprit may well be your antivirus software. If you own more than one malware protection software, make sure you check both.

There are so far two antivirus/malware protection software known to cause this problem with Toast when burning files to disc or saving them to a disc image.

  1. McAfee (any of their security software)
  2. Acronis Cyberprotect Home Office

In order to successfully burn your files or save them to a disc image file in Toast, protection from either of these antivirus software needs to be disabled or turned off temporarily. If you have a different antivirus software, such as Norton 360, you may want to check anyway if it is interfering with the burning process by turning off its protection as well. Please proceed to the next sections.

Turning off McAfee Antivirus protection

  1. Click the McAfee M icon on your menu bar, at the top of the screen.
  2. Select (product name) Console. For example, McAfee Total Protection Console.
  3. Click the gear icon at the top right. You'll see the preferences in the Mac Security menu.

    Mac security menu
     
  4. You can choose one of the options in the Mac Security menu. Turn off both the Real-time scanning and Firewall. You may need to click on the lock icon on the bottom left-hand corner to make changes.

    Use the Real-time scanning toggle switch to turn off the feature:
    mcafee real-time scanning switch

    Use the Firewall toggle switch to turn off the feature:
    mcafee firewall toggle switch
     
  5. After changing your preferences, click the padlock to the lock position to secure your changes.

Now try burning your Toast DVD or Blu-ray disc or disc image project again. It should complete this time with no errors.

Turning off Acronis Cyberprotect Home Office protection

  1. Launch Acronis and click on the Protection tab on the left-hand side.
  2. On the next column, at the bottom, you will see a "Turn off protection" button, click on that.

    Turning off Acronis protection
     
  3. If it asks if you are sure you want to turn off protection, select "Until restart", or "Permanently" (you can still turn it back on later if you wish).

    Acronis - turn off protection until restart.
     
  4. Click the Turn Off button.

Now try burning your Toast DVD or Blu-ray disc or disc image project again. It should complete this time with no errors.

What if you do not own either McAfee or Acronis software?

If you do not own either McAfee or Acronis, other antimalware software could also cause this problem. Below are the steps to disable Norton (any of its security software) protection. If you own something else, please refer to the software's documentation to turn off its protection, or reach out to its customer support team.

Turning off Norton protection

  1. Open your Norton device security product.
  2. If you see the My Norton window, next to Device Security, click Open.
  3. In the Norton product main window, click Advanced or Settings.
  4. On the left pane, click Protect My Mac.
  5. In the Automatic Scans row, move the switch to off.
  6. On the left pane, click Firewall.
  7. In the Connection Blocking row, move the switch to off.
  8. In the Vulnerability Protection row, move the switch to off.

You can use the Fix Now option in the main window to turn protection back on.

Now you're done. We hope this article fixed the problem for you.

 

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