Roxio: Your VideoWave, MyDVD, or SlideShow Assistant project will not play or has jerky playback in preview

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Symptoms

When attempting to play your VideoWave production for a preview, video playback will not start, although the audio track plays fine. In some cases, playback starts and stops intermittently, or is jerky. You may eventually get a "not responding" message in the title bar and the application freezes. The same thing happens when you try to preview your slideshow project in SlideShow Assistant, or your DVD production in MyDVD.

Cause

In some cases, your graphics card's *device drivers may be outdated and you simply need to update them to the latest release version. In other cases, your graphics card just might not be properly supported by the software.

*A device driver is a small piece of software that makes communication possible between your particular hardware device (e.g., a graphics card or webcam) and the operating system.

Resolution

Most modern computer systems (both desktops and laptops) have two graphics processing units, or GPUs. One is an integrated GPU, or IGP (integrated graphics processor), and the other a discrete GPU or graphics card. An IGP is built into the system processor (or CPU), and the discrete GPU is separate from it, hence the term "discrete". To avoid any lengthy discussions on these two, please refer to this KB article from Intel. So other than updating an outdated GPU device driver, as mentioned above, you will also have the option to choose which GPU to use for your Roxio application. To go in more detail, continue to the next sections.

Device drivers outdated

The safest place to start is to always assume that your GPU drivers are outdated. You will need to check the manufacturer's website if they are offering updated device drivers for you to download and install. It is common practice these days for the manufacturer to offer an easy way to update your GPU drivers. That is, by giving you the option to download and install a utility that will automatically detect what kind of GPU model you have and search for the best drivers for it, and download and install that version. Don't worry, they always give clear instructions on how to undertake this entire process.

There are currently only *three major players in the GPU manufacturing scene for the PC platform and you, most likely than not, have one of theirs on your system.

Check your user manual to find out which manufacturer you should be going to, and then click on the below links accordingly.

Once you have updated your GPU drivers, make sure you reboot your system (if not prompted after the update) before trying your Roxio project again. If the problem remains, proceed to the next section.

*There is a fourth player that has been thrown into the mix recently, but it only caters to its own proprietary systems. Yep, that's Apple and its M1 silicon that contain integrated GPUs.

GPU Incompatible or not properly supported

It is customary these days for GPU manufacturers to release a new model every 2 years. As such, the Roxio software you are using might not have proper support for that new GPU yet. Although we offer a workaround for this issue in this section, it is still a good idea to reach out to technical support if you do find out that your GPU is not properly supported, so that it can be investigated properly and confirmed if an *update to the software is called for.

As mentioned in the previous section, most systems (and most likely, yours too) have both a discrete GPU and an integrated one, or IGP. Windows 10 and later provides its users the option to select which of the two GPUs will be used for selected applications. By default though, Windows will select what it thinks is the best one according to the required load of the program it is currently running. In some cases, however, Windows might not know better, so you need to decide for yourself which GPU to use.

Follow these steps:

  1. Make sure VideoWave or SlideShow Assistant is not running. If so, exit out of them now.
  2. Press the Windows key Windows logo on your keyboard and then type graphics settings.
  3. When you see the below item appear, hit the Enter (or Return) key on your keyboard.

    graphics settings
     
  4. The Graphics settings window should come up. Under the "Choose an app to set preference" title, make sure "Desktop app" is selected and click Browse.

    graphics performance preference
     
  5. If you know where your application's executable is located, go ahead and navigate to it and add it to the list, then skip to step #9. Otherwise, proceed to the next step.
  6. For Videowave, navigate to C:\Program Files (x86)\Roxio Creator NXT %version%\VideoUI, and then select and add VideoWave15.exe. Note that the "15" in the filename will differ depending on version.
  7. For SlideShow Assistant, navigate to C:\Program Files (x86)\Roxio Creator NXT %version%\Common, and then select and add RoxWizardLauncher15.exe. Again, the number will differ depending on version.
  8. For MyDVD, navigate to C:\Program Files\Roxio Creator MyDVD, and then select and add MyDVDApp.exe.
  9. Once they have been added, go back to each and click on them, and click again on the "Options" button.

    graphics options
     
  10. You will see options for Let Windows decide, Power saving, or High performance. Choose High Performance, which is always your discrete GPU, and then click Save.

    High performance
     
  11. Exit the Graphics settings window.

 

Launch VideoWave or SlideShow Assistant, and load your saved project, or create a new one if you did not save the previous one. You should now find that preview playback is good and smooth.

*But do note that we have internal timelines for releasing updates that need to be strictly adhered to for reasons too complicated to discuss. This means we cannot always release an update whenever an issue is reported, but there will always be room for consideration.

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