WordPerfect print error "unable to initialize output device" when accessing WP via Remote Desktop

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Symptoms

When accessing WordPerfect via Remote Desktop (RDP), an error is seen when printing, "Unable to initialize output device".

Cause

By default, WordPerfect attempts to initialize all available printers in the background when the print dialog is opened, however this operation may interfere with printing as many printers are remote in an RDP connection.

Resolution

Change the "Init All Printers In Background" setting within WordPerfect to Off (0).

These steps involve editing the Windows Registry. As such it is important to backup the registry before proceeding:

https://support.microsoft.com/en-us/topic/how-to-back-up-and-restore-the-registry-in-windows-855140ad-e318-2a13-2829-d428a2ab0692

Here's how to change the setting:

  1. Save your work in WordPerfect
  2. Close all WordPerfect Windows.
  3. Run Regedit:
    1. Press WinKey + R on the keyboard
    2. Type Regedit.exe and click OK
    3. Click Yes if prompted for permission and/or enter administrator user credentials if prompted.
  4. In the left column of Regedit, browse to this key:
    HKEY_CURRENT_USER\SOFTWARE\Corel\PrintEngine\21\Timeouts
  5. In the right column of reedit, double click on "InitAllPrintersInBackground"
  6. In the Edit DWord (32-bit) dialog, change the Value Data 1 to 0 (zero) and click OK
  7. Close RegEdit
  8. Retry printing in WordPerfect.

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