Sintomi
Quando si masterizza un disco in Toast, viene visualizzato il messaggio di errore "Impossibile completare l'ultimo comando perché esiste già un elemento con quel nome. Codice risultato = -48".
Causa
L' errore Codice risultato = -48 è semplicemente un errore di nome file duplicato. Toast memorizza temporaneamente i propri progetti disco in Documents > Roxio Converted Items. A volte, i progetti disco che si tenta di masterizzare possono avere titoli duplicati di ciò che è stato memorizzato nella cartella Roxio Converted Items.
Ma possono anche trovarsi altrove. Le sezioni seguenti forniscono alcune informazioni su dove cercare questi file duplicati.
Risoluzione
Poiché la causa principale di questo errore sono i nomi di file duplicati, è possibile eseguire una delle seguenti operazioni per risolvere il problema:
- Individua i file duplicati ed eliminali o rinominali.
- Riavvia il Mac per eliminare i file temporanei.
- Eliminare la cache dell'applicazione.
- Elimina la cache di sistema.
- Smontare tutti i file immagine disco montati.
- Creare un nuovo account utente.
Individua i file duplicati
Se non hai ancora provato a controllare le cartelle dei tuoi file (ad esempio Immagini, Musica, Filmati, Documenti), fallo ora e vedi se c'è un altro file che ha lo stesso nome del tuo attuale progetto DVD. Se ne vedi uno, isola il file o eliminalo, se possibile.
Riavvia il Mac
I file temporanei vengono presumibilmente eliminati dopo che Toast li ha utilizzati. In rari casi, questi file non vengono eliminati a causa di qualche problema tecnico temporaneo. Forse il tuo computer Mac ha semplicemente bisogno di un po' di incoraggiamento per eliminare detti file. A tale scopo, è possibile eseguire un riavvio.
Se l'errore persiste dopo aver eseguito un riavvio, i file duplicati potrebbero essere archiviati altrove nel sistema.
Eliminazione della cache dell'applicazione
Di norma, i file memorizzati nella cache sono file temporanei di cui puoi sbarazzarti in modo sicuro. Ci sono volte, tuttavia, che alcuni di questi file temporanei aiutano il tuo sistema a funzionare in modo ottimale. Quindi, prima di tuffarti e fare zapping di quei file memorizzati nella cache, assicurati di eseguire prima il backup del tuo sistema in modo da avere la possibilità di ripristinare i tuoi file importanti se tutto va storto.
Ecco come accedere alla cache dell'applicazione in macOS nel caso in cui si voglia andare a dare un'occhiata lì:
- Apri il Finder. Dal menu Vai, seleziona Vai alla cartella...
Un modo più veloce per visualizzare "Vai alla cartella" è aprire il Finder e premere Comando + Maiusc + G. - Verrà visualizzata una finestra di dialogo. Digita~/Libreria/Cache/ (non dimenticare il carattere tilde) e quindi fai clic sul pulsante Vai o premi Invio/Invio sulla tastiera.
- Verrà visualizzata la cartella della cache dell'applicazione.
- Se sei in visualizzazione a colonne, come nello screenshot sopra, fai clic una volta sulla cartella Cache per assicurarti che sia selezionata e premi Comando + A per selezionare tutti i file e le cartelle sotto di essa. Ora, fai clic con il pulsante destro del mouse sui file evidenziati e seleziona Sposta nel cestino per eliminarli tutti.
- Riavvia il Mac e verifica se il problema è stato risolto.
Eliminazione della cache di sistema
Se l'eliminazione della cache dell'applicazione non risolve il problema, potresti voler esaminare anche l'eliminazione della cache di sistema. Per fare ciò, segui gli stessi passaggi di cui sopra, ma invece di digitare ~/Library/Caches, digitalo senza il carattere tilde, in questo modo: /Library/Caches.
Otterrai qualcosa di simile allo screenshot qui sotto. Potresti avere più file di quelli mostrati. Premi Comando + A per selezionare tutti i file nella cartella Cache, fai clic con il pulsante destro del mouse e seleziona Sposta nel Cestino. Ti verrà chiesto di inserire la password dell'amministratore: digitala e fai clic su OK per procedere.
Se ricevi un messaggio che ti informa che non disponi dell'autorizzazione per accedere ad alcuni elementi, lasciali stare. Riavvia il Mac e verifica se il problema è stato risolto.
È possibile che sia in uso un file immagine disco
È anche possibile che il file duplicato sia attualmente in uso - un esempio è se il duplicato è un file immagine disco ISO ed è attualmente montato. Se stai tentando di creare una versione più recente del file ISO e gli hai dato lo stesso nome di quello esistente, Toast non sarà in grado di sovrascriverlo e apportare le modifiche necessarie poiché è in uso, e quindi verrà visualizzato un errore "Codice risultato = -48". Smontare il file immagine e rinominarlo.
Creare un nuovo account utente
Se tutto il resto fallisce, crea un nuovo account amministratore e accedi, reinstalla Toast, quindi prova il tuo progetto lì. Naturalmente dovrai rendere disponibili i file che utilizzerai all'altro account utente. Ecco come fare se hai bisogno di istruzioni. Il nuovo account utente serve solo per isolare il problema. Se sei in grado di completare con successo il tuo progetto con il nuovo account utente, questo confermerà che la causa del problema esiste da qualche parte nel tuo account principale. Apri un ticket di supporto qui.
Was this article helpful?
Tell us how we can improve it.