症状
Toast でディスクを書き込んでいるときに、セッションが終了し、"結果コード= -5000 のため、ディスクを記録できませんでしたALRT_251_MESSAGE4というエラーが表示されます。
原因
Toast でディスクを書き込もうとしたときにこのエラー メッセージが表示される場合は、Mac コンピューターに課せられた特定の制限が原因である可能性があります。
手記:
この記事は、Toast のすべてのバージョンと、Toast Burn、Toast DVD、Toast Audio などの派生製品に適用されます。
エラー -5000 は "アクセスが拒否されました" というエラー メッセージです。したがって、この問題は、ファイルへのアクセスが制限されているアクセス許可に関係しています。これらの制限により、Toast やその他のアプリケーションは、タスクの実行に必要な特定の MacOS リソースにアクセスできなくなります。
解決
Toast がディスクの書き込みに必要なアクセス許可を持っていることを確認するために、次の点を確認します。
- 管理対象アカウント
- サードパーティのウイルス対策ソフトウェアとファイアウォール。
- フルディスクアクセス。
- ファイルのアクセス許可。
「管理対象アカウント」とは何ですか?
macOS Mojave以前では、管理対象アカウントは、ペアレンタルコントロールを使用して使用を制限する特殊なアカウントです。これらのタイプのアカウントは、子供や家族のゲストにMacコンピュータへの無料アクセスを許可すると同時に、システム設定の変更や、使用できるアプリケーションやアクセスできるWebサイトの制限を禁止する場合に最適です。
macOS Catalina以降では、ペアレンタルコントロールは、ペアレンタルコントロールとほぼ同じように機能するスクリーンタイムに置き換えられました。
管理対象アカウントにサインインしている場合は、管理者アカウントで Toast を実行します。さまざまなユーザタイプとその権限、およびユーザタイプから別のユーザタイプへの変更方法について詳しくは、Appleのサポート記事「Macでユーザ、ゲスト、グループを設定する」を参照してください。
他社製のウイルス対策ソフトウェアとmacOSファイアウォール
サードパーティのウイルス対策ソフトウェア(Bitdefender、McAfee、Norton、Malwarebytes Premiumなど)がインストールされていてシステムを保護している場合は、一時的に無効にして、問題が解決するかどうかを確認します。その場合は、保護設定を微調整して、トーストに例外を設けることができます。手順については、ソフトウェアのヘルプドキュメントを参照してください。
組み込みのmacOSファイアウォールは、不要な着信や接続をブロックすることにより、Macコンピューターをより安全にします。ただし、特定のアプリが完全にブロックされ、ネットワーク上のリソースにアクセスしたり、リソースと通信したりできない場合、これは問題になる可能性があります。書き込もうとしているファイルがネットワーク接続ストレージ(NAS)またはその他のネットワークの場所に保存されている場合は、ファイアウォールがエラーの原因である可能性があります。
ファイアウォールを一時的に無効にして、問題が解決するかどうかを確認してください。その場合は、ファイアウォール オプションを変更して、一部のアプリやサービスがファイアウォール経由で要求を受信できるようにすることをお勧めします。
macOSのファイアウォールに変更を加える方法については、Appleのサポート記事「ファイアウォールでMacへの接続をブロックする」を参照してください。サードパーティのファイアウォールを使用している場合は、ソフトウェアのヘルプドキュメントで手順を参照してください。
Toast へのフル ディスク アクセスの許可
ウイルス対策ソフトウェアがインストールされていない場合や、ファイアウォールが有効になっていない場合 (または、両方が一時的に無効になっているのに問題が解決しない場合) は、システム環境設定で Toast にフルディスク アクセス許可が与えられているかどうかを確認します。そうでない場合、またはトーストがアプリの一覧にない場合は、次の手順に従います。
- 「システム環境設定」→「セキュリティとプライバシー」→「プライバシー」を開き→フルディスクアクセスを選択します。
- 左下隅にある[ロック]をクリックし、パスワードを入力して変更を加えます。
- 右ペインの一覧に [トースト] が表示されている場合は、チェックボックスにチェックを入れます。
- トーストが表示されない場合は、次の手順に従ってアプリを一覧に追加します。
- プラスボタンをクリックします。
- 「アプリケーション」から「トースト」を選択します
- [開く] をクリックして確定します5.カギをクリックして変更を保存します。終了して再起動するまで、トーストはファイルにアクセスできないというダイアログ ボックスが表示される場合があります。「今すぐ終了」ボタンをクリックします。
- その後、Toast を再度起動します。これで、コンピューターにフルディスクアクセスができるようになります。
ファイルの共有と権限
上記のいずれでも問題が解決しない場合は、ファイルの 共有と権限 の設定により、ファイルに変更を加えることができない可能性があります。ディスクに書き込むファイルを選択し、メニュー バーの [ファイル] > [情報を見る] をクリックします。
「情報を見る」ウインドウで、「共有と権限」セクションが表示されるまで一番下までスクロールします。ファイルは「読み取り専用」または「アクセスなし」のいずれかに設定できます。「読み取りと書き込み」に設定して、問題が解決するかどうかを確認してください。「共有とアクセス権」でできることの詳細については、Appleのサポート記事「Macでファイル、フォルダ、またはディスクのアクセス権を変更する」を参照してください。
Was this article helpful?
Tell us how we can improve it.