Roxio Creator NXT (all versions): Error code 1011 on Launching the application

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Symptoms

You keep getting an Error 1011 message - “You do not appear to be a registered user. Please re-install the application or call customer support with error code 1011”

Note:

This issue can affect the entire Creator NXT family of products that came out since 2017 onward. Namely:

As well as Easy VHS to DVD Plus.

Cause

The problem is caused by an incorrect install method or a corrupted JSON file, where the registration information is stored.

1011 registration error

You will notice the problem upon launching your Creator NXT (either Standard or Pro versions) application, where normally you would get the blue or orange (depending on your version) Creator NXT splash screen, you instead get an error window saying “You do not appear to be a registered user. Please re-install the application or call customer support with error code 1011”, regardless of whether you have already previously registered the product or not, this most likely means that you did not properly install the software package.

Resolution

As earlier stated, the problem can happen in either of two possible scenarios:

  1. The product was not installed the way it should have been;
  2. The registration file somehow got deleted or corrupted.

The proper way to install the product

Going into more detail on the first point, there are two ways to install Creator NXT, but only one correct way. The correct way is by installing the product using what is called the “stub installer”.

The stub installer looks like this:

stub installer icon

Aside from installing all (or selected) component packages, using the stub installer registers the product for you and associates it with the machine you install it on.

The installer stub saves all registration information to a file on your computer, named “userData.json”. This file is created only when you use the installer stub to install the product. If you install the product using its setup.exe file, located in the Creator NXT installer folder, you are effectively bypassing the product registration routine.

The screenshot below shows how to identify the setup.exe file.

setup.exe file

You might see only a file named “setup” (instead of “setup.exe”) if you do not have the File name extensions option box checked.

If you used the setup.exe file to install Creator NXT, although it would still fully install, the product does not get associated with your computer (via the product registration routine), and you thus end up with the 1011 error. So, to avoid this, you need to install (or reinstall) the product using the stub installer.

Corrupted or missing registration file

Moving on to the next point, a corrupted or missing registration file (i.e., userData.json file) can also cause the 1011 registration error message. Regardless of whatever caused the corruption, or how it went missing (accidental deletion, antivirus software blocking the file, etc.), would have the same effect as the first point made.

The userData.json file is located in C:\ProgramData\Corel\StubFramework\Creator. The “ProgramData” folder is a hidden folder, which you would not normally be able to see, unless you have the Hidden items option box checked, as shown in the screenshot below.

Program Data folder

Once in the “Creator” folder, you should see a number of subfolders named “19.0” (NXT 6), “20.0” (NXT 7), or “21.0” (NXT 8), depending on which versions of Creator NXT you currently have installed or installed in the past. See screenshot below.

Creator subfolder

Note:

If you have any of the other Roxio products installed (noted at the beginning of this article) and are getting the 1011 error, you will not have a “Creator” folder but a different one. Please be guided accordingly:

Opening the version number folder will reveal the userData.json file.

UserData.json registration file

Whether the folder or file is present or not, if you are getting the 1011 error, you need to delete the version number folder and run through the installer stub again (see previous section, “The proper way to install the product”) in order to recreate or refresh the data file. Once done, try launching Creator NXT again – the application should now come up and function properly.

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