WordPerfect: Error "Invalid codepage error" when changing the System Locale in Windows 11

4 users found this article helpful

Symptoms:

In WordPerfect, one may receive an Invalid Codepage error message in some circumstances. This procedure can resolve this error.

Cause:

WordPerfect is a codepage based application. If the Windows codepage is set to a value which WordPerfect does not support, one may see errors like "Invalid Codepage" when using WordPerfect.

Resolution:

Change the system locale in Windows 11 to US English:

  1. Open Windows Settings
    1. To open System Settings, press the Windows key + i shortcut on the keyboard
    2. OR click on Start ==> Settings
    3. OR one can also use the search box on the taskbar to search for "Settings". Then click Settings to open it.
  2. In Windows Settings, click Time & language, click "Language & region" on the right pane of your screen
  3. This will take you to the Region settings pane, under Administrative.
  4. Click the Change system locale button.
  5. Select the language you want for the system locale from the list. We recommend US English. Click OK to apply your changes.
    1. NOTE: This change will affect all user accounts on the computer.
  6. Do not check the "BETA: Use Unicode UTF-8 for worldwide language support" checkbox.
  7. Click OK. You will be prompted to restart your computer.
  8. Restart your computer.

Was this article helpful?

Tell us how we can improve it.