Symptoms
During installation of your Roxio software, you get an error stating, "Can't connect to the Internet. Please check your connection and try again".
This happens even though you obviously have a good Internet connection.
Cause
Your antivirus, firewall, or other system and network security measures could be configured to block outgoing connections to unrecognized web servers or sites over the Internet, preventing the download of Roxio installer files.
Resolution
System and network security measures can exist in the form of installed software on your computer, or a feature that is built in to your network router/modem.
Check and Edit your Windows Hosts File
The Windows hosts file is a plain text file that maps hostnames to IP addresses. It is used by the operating system to resolve domain names into IP addresses. The hosts file is located in C:\Windows\system32\drivers\etc
on Windows 10 and 11. If you’re experiencing issues accessing certain websites or downloading files from the Internet, it’s possible that the hosts file is blocking access to those sites.
To check if the Windows Hosts file has Corel links blocking the registration process, follow these steps:
- Press Windows key + R to open the Run dialogue box
- Type in drivers and press Enter
- Double-click on the folder etc
- NOTE: Because of system permissions, you will not be able to open the HOSTS file and save any changes from within this folder
- Copy the HOSTS file to the Desktop; Minimize this window
- Right-click the HOSTS file on the Desktop, Choose Open With... then Notepad
- In this folder look for the following entries and remove them:
- 0.0.0.0 apps.corel.com
- 0.0.0.0 mc.corel.com
- 0.0.0.0 origin-mc.corel.com
- 0.0.0.0 iws.corel.com
- 127.0.0.1 mc.corel.co
- 127.0.0.1 apps.corel.com
- 127.0.0.1 origin-mc.corel.com
- 127.0.0.1 iws.corel.com
Once you have removed these entries from the file, Save the file by pressing CTRL+ S. After which, you can copy and paste the file back into the ETC folder, which was minimized, and agreeing to the security prompt.
Temporarily Disable your Antivirus or Firewall software
The settings you have applied to your antivirus or firewall software will protect your from various malware and hacker attacks, but may also be too stringent for other required tasks, such as that of installing new software. You will need to temporarily disable your antivirus and firewall software until your Roxio software has been successfully installed. If you have already disabled these, you will need to check the settings in your router.
Temporarily Disable your Router's Security Settings
It is strongly recommended that you consult your router's user guide or Internet service provider's support team for assistance. The specific setting that could be causing this issue will depend on your router’s make and model. There are, however, some common settings that could be blocking outgoing connections to specific web servers, which may include:
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Firewall settings: Your router’s firewall settings might be blocking outgoing connections to specific web servers. You can try disabling your router’s firewall temporarily to see if that resolves the issue.
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Port forwarding settings: If you have port forwarding enabled on your router, it could be blocking outgoing connections to specific web servers. You can try disabling port forwarding temporarily to see if that resolves the issue.
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Parental control settings: If you have parental control settings enabled on your router, it could be blocking outgoing connections to specific web servers. You can try disabling parental control settings temporarily to see if that resolves the issue.
To access your router’s settings, you can follow these general steps:
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Open a web browser on a device that is connected to your router.
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Type your router’s IP address into the address bar of the web browser and press Enter. You can find your router’s IP address in your router’s user manual or by contacting your router’s manufacturer.
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Enter your router’s username and password when prompted. You can find your router’s default username and password in your router’s user manual or by contacting your router’s manufacturer.
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Once you have logged in to your router’s settings, you can navigate to the relevant settings page and make any necessary changes.
We hope this has helped you resolve your Roxio installation issue. If not, you may reach out to our technical support team for further assistance.
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